
                         DATABASE DESKTOP [by Marcelo A. dos Santos]

Para confeccionar tabelas banco de dados pode-se usar o Database Desktop, ja incluso
no CD de instalacao do Delphi. Com certeza a sua maquina ja o tem instalado... 

Para acessa-lo, clique no menu Iniciar>Programas>Borland Delphi>Database Desktop.

CONFECCIONANDO UMA TABELA BANCO DE DADOS:

Clique no menu File>New>Table... e escolha em Create Table>Table Type a opcao Paradox 7, 
versao mais atual e OK.

==============================================================================================

...As tabelas Paradox possuem a extencao (*.DB). Cada tabela e dados tem um arquivo associado. 
O Paradox possui um rico conjunto de tipo de dados (campos de AutoInc e Time), sendo o Delphi 
melhor adaptado para acessa-lo do que a tabelas Dbase e similares. 

Sobre as limitacoes do banco de dados Paradox

127 tabelas abertas por sistema;
254 tabelas abertas por sistema (versao 4.0 ou superior do BDE);
255 registros em transacao em uma tebela;
512 arquivos fisicos abertos (DB, PX, MB, X??, Y??, VAL, TV);
1024 arquivos fisicos abertos (DB, PX, MB, X??, Y??, VAL, TV) (versao 4.0 ou superior do BDE);
300 usuarios para um arquivo PDOXUSRS.NET;
255 campos por tabela;
2 bilhoes de registros por tabela;
127 indices secundarios por tabela; 
16 campos como chave composta;
255 usuarios concorrentes por tabela...

==============================================================================================

A janela ’Create Paradox’ sera exibida, aonde:

Field roster: agrupamento de controles composto das colunas Nome do Campo - Tipo - 
Tamanho - Chave [Fied Name - Type - Size - Key].
    
Estas colunas especificam o nome, tipo, tamanho e exclusividade de cada campo de uma tabela 
banco de dados.

======================================================================
   |    Field Name    |    Type   |    Size   |    Key   |
======================================================================
 1 |                  |           |           |          |
   |                  |           |           |          |

»» Na coluna Field Name (Nome do Campo), pode-se digitar qualquer palavra para 
a identificacao do campo na tabela banco de dados.

»» Type (Tipo), existem uma sequencia de valores que podem ser usados para o tipo
de campo da tabela banco de dados:

A .................. Alfanumerico 
N .................. Numerico      
$ .................. Monetario    
S .................. Short Integer
I .................. Integer
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D .................. Data
T .................. Hora
@ .................. Data e hora de modificacao
M .................. Memo
G .................. Grafico
L .................. Logico
+ .................. Autoincremental

Para visualizar esta lista de opcoes, clique com o botao direito do mouse dentro
da coluna Type ou insira o foco do cursor na coluna Type e pressione a barra de 
espacamento de texto.  

»» Size (Tamanho), especifica o limite de caracteres (letras) que um campo 
Alfanumerico podera receber, de 1 a 255 caracteres.

»» Key (Chave), impede a entrada de valores identicos a um determinado campo.
- Para acionar a chave de violacao, insira o foco do cursor na coluna Key e 
pressione alguma tecla ou clique duas vezes com o botao direito do mouse, o
sinal de asterisco sera inserido.

Na caixa de combinacao Table Properties (Propriedades da tabela), configuramos o 
perfil de uma tabela banco de dados:

Valid Checks ........... Registra as regras de validacoes para os campos.
(Checagens validas)
Table Lookup ........... Indica que um valor (dado) atribuido a um determinado campo 
(Observar Tabela)        tem que estar gravado em uma outra tabela.
Secondary Indexes ...... Cria indices secundarios.
(Indices  secundarios)
Referencial Integrity .. Cria integridade referencial.
(Integridade Referencial)
Password Security ...... Cria senhas, protegendo o acesso a uma tabela banco de dados.
(Senha de Seguranca)
Table Language ......... Especifica o driver utilizado para a confeccao de tabela banco
(Linguagem de Tabela)    de dados, Paradoxy e o mais usado.
Dependent Tables ....... Exibe todas as tabelas banco de dados dependentes da integridade
(Tabelas Dependentes)    referencial.

Obs: ’Valid Checks e o controle para confeccoes de nome, tipo e tamanho de cada campo de
uma tabela banco de dados’.

A caixa de checagem Required Field (Campo requerido), impede a insercao de um
novo registro caso um deteminado campo esteja configurado para listar (coonstar)
em todos os registros de uma tabela banco de dados. Vale a pena recordar que; 
tabelas bancos de dados sao compostas de campos para receberem e armazenarem
registros, cada registro contem dados que preenchem os campos de uma determinada 
tabela banco de dados. Para configurar um campo como primordial para uma tabela
banco de dados, clique com o botao direito direito do mouse dentro da caixa de
checagem de campo requerido.  

As seguintes caixas de edicoes nao sao muito usadas:

Minimum value:.............. Valor minimo que um campo pode assumir.
Maximum value:.............. Valor maximo que um campo pode assumir.
Default value:.............. Valor padrao para um campo, em cada novo registro o 
campo recebera determinado valor.
Picture:.................... Mascara a ser imposta ao campo.
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O botao ’Assist...’ (Assistente de mascara):

Verifica, restaura, testa mascaras e apresenta samples (modelos) de mascaras a ser imposta
ao campo.

A caixa de checagem Pack Table (Tabela de pacote):

Se checada (marcada com o clique do mouse ), sempre realizara compactacao automatica da
tabela banco de dados, eliminando registros vazios.
 
O esboco abaixo demonstra um campo de tabela ja implementado.

======================================================================
   |    Field Name    |    Type   |    Size   |    Key   |
======================================================================
 1 |Nome              |     A     |         25|     *    |
   |                  |           |           |          |

Para criar um novo campo, pressione as teclas ENTER ou TAB.

Uma propriedade de funcao importante em uma tabela banco de dados e Secondary Indexes
(Indexacao secundaria), cria indices secundarios para implementarmos buscas aproximadas
por um valor de um determinado campo. Para configurar essa propriedade:

Clique no item ’Secondary Indexes’ e logo apos no botao ’Define...’

A janela Define Secondary Indexes (Definir Indices Secundarios) e apresentada:

1 - Escolha um campo na caixa de lista ’Fields:’ clicando sobre um item que o representa...
2 - Clique agora no botao [->] com a imagem de uma seta direcioanl a direita para o campo 
    escolhido ser movido para a caixa de lista ’Indexed Field’ (campo indexado)...  
3 - Clique na caixa de checagem ’Maintained’...
4 - Clique no botao ’OK’...
5 - A janela ’Save Index As’ e apresentada, digite um nome qualquer na caixa de edicao ’Index
    Name:’ e pressione o botao ’OK’...
6 - ...e ’OK’ novamente para fechar a janela Define Secondary Indexes.

Para salvar a tabela banco de dados, clique no botao ’Save As...’, escolha ou crie uma pasta 
para criar o arquivo que contem a estrutura de sua tabela. 

Caso mais tarde queira reconfigurar essa mesma tabela, sera necessario abri-la:

A - Clique no menu File>Open>Table... e localize a pasta aonde foi salvo o arquivo *.db 
que contem as estruturas salvas em sua tabela banco de dados...
B - Para reestrutura-la, clique no menu Table>Restructure...

  =====================================================================
  | "IMPLEMENTANDO CODIGO PARA A REALIZACAO DE UMA BUSCA APROXIMADA"  |            
  =====================================================================
  |                                                                   |   
  |  CONFIGURANDO A BUSCA APROXIMADA EM TEMPO DE PROJETO:             | 
  |                                                                   |
  |  Abra o seu projeto Delphi (caso ja o tenha). Na propriedade      |
  |  INDEXNAME do componente TTABLE selecione e clique no index       |
  |  name recem criado no Database Desktop.                           |
  |                                                                   |
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  |  Insira um componente TEdit no seu TForm de consultas dos dados.  |
  |  No evento OnChange do TEdit digite:                              |
  |                                                                   |
  |  Table1.FindNearest([Edit1.Text]);                                |
  |                                                                   |
  |                                                                   |
  |===================================================================|
   ===================================================================

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

++++++++++A BARRA DE MENUS E COMANDOS DO DATABASE DESKTOP 7:+++++++++++

[Menu File]
|New______ _ Qbe Query_ (cria e salva uma consulta sql de ou para uma determinada tabela)
|         |_ Sql File _ (cria um arquivo com sentenca sql) 
|         |_ Table    _ (cria e salva um arquivo contendo as estruturas de uma tabela)  
|Open_____ _ Qbe Query_ (abre um arquivo contendo os comandos de sql de uma tabela)
|         |_ Sql File _ (abre um arquivo contendo uma sentenca sql)
|         |_ Table    _ (abre um arquivo contendo as estruras de uma tabela)
|Close_________________ (fecha um arquivo aberto)
|
|Save__________________ (salva um arquivo)
|
|Save As_______________ (redireciona o salvar de um arquivo existente)
| 
|Working Directory_____ (configura o caminho padrao para uma pasta de trabalho)
|
|Private Directory_____ (configura o caminho padrao para uma pasta de trabalho)  

[Menu Editar]
|
|Undo__________________ (desfaz ultimo comando)
|
|Cut___________________ (envia dados para area de transferencia)
|
|Copy__________________ (envia dados para area de transferencia)
|
|Paste_________________ (cola dados enviados para a area de transferencia)
|
|Paste Link____________ (cola como atalho)
|
|Copy To_______________ (Copia para uma deteminada area de transferencia)
|
|Paste From____________ (cola dados enviados para uma determinada area de transferencia)
|
|Delete________________ (apaga o conteudo de um campo de tabela)
|
|Selec All_____________ (seleciona todos os campos de um registro de tabela)
|
|Preferences___________ (configura a interface do Database Desktop)
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[Menu View]
|
|Field View____________ (insere o foco do cursor em campo de tabela)
|
|Persistent Field View_ (insere o foco do cursor em todos os campos de tabela)

[Menu Table]
|
|Edit Data_____________ (libera edicao para um campo de tabela)
|
|View Data_____________ (insere o foco do cursor em todos os campos de tabela)
|
|Info Structure________ (exibe informacoes das estruturas de uma tabela somente leitura)
|
|Reestructure__________ (exibe estruturas para reedicao de uma tabela)
|
|Notify on_____________ (notifica a transmissao de dados cliente/servidor)
|
|Strict Translation____ (traduz caracteres disponiveis OEM e ANSI)  
|
|Table View Properties 
|                       
|_______________ Save__ (salva visao atual de tabela)
                |
                |Restore(restaura visao de tabela) 
                |
                |Delete (apaga a visao de uma tabela) 

[Menu Record]
|
|Next__________________ (avanca cursor para proxima linha de registro de tabela)
|
|Previous______________ (retorna cursor uma linha acima do registro atual)
|
|Next Set______________ (avanca cursor para a ultima linha de registro)
|
|Previous Set__________ (retorna cursor para a primeira linha de registro)
|
|First_________________ (retorna cursor para a primeira linha de registro)
|
|Last__________________ (avanca cursor para a ultima linha de registro)
|
|Insert________________ (insere uma linha de novo registro) 
|
|Delete________________ (apaga um linha de registro)
|
|Lock__________________ (trava uma linha de registro)
|
|Unlock________________ (destrava uma linha de registro)
|
|Post/Keep Locked______ (insere e mantem trava em uma linha de registro)
|
|Lockup Help___________ (ajuda sobre travamento)
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|
|Move Help_____________ (ajuda sobre a mocao de registros)

[Menu Tools]
|
|Alias Manager_________ (configura alias e driver para uma tabela banco de dados)
|
|Utilities______ Add___ (adiciona linhas de registros em determinada tabela)
                |
                |Copy__ (copia uma tabela) 
                |
                |Delete (apaga uma tabela)
                |
                |Empty_ (apaga todos os registros de uma tabela)
                |
                |Info St(exibe informacoes das estruturas de uma tabela somente leitura) 
                |    
                |Rename (renomeia uma determinada tabela)
                |
                |Sort__ (cria copia de estrutura de uma determinada tabela) 
                |
                |Restruc(exibe estruturas para reedicao de uma tabela)
                |
                |Subtrac(apaga registros de determinadas tabelas banco de dados)
                |
                |Passwrd(Insere e apaga senhas de acessos em tabelas banco de dados)

[Menu Window]
|
|Posiciona e configura estados e posicoes das janelas

[Menu Help]
|
|Exibe conteudo de arquivo de ajuda ’sobre’ o Database Desktop

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
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